Rhino C++ API  8.6
Public Types | List of all members
RhSimplifyCurveFlags Class Reference

#include <rhinoSdkUtilities.h>

Public Types

enum  Flags {
  DONT_SPLIT_FMK = (1 << 0), DONT_REBUILD_LINES = (1 << 1), DONT_REBUILD_ARCS = (1 << 2), DONT_REBUILD_RATIONALS = (1 << 3),
  DONT_ADJUST_G1 = (1 << 4), DONT_MERGE = (1 << 5)
}
 

Detailed Description

Description Enumeration describing option to RhinoSimplifyCurve(...) See Also RhinoSimplifyCurve

Member Enumeration Documentation

◆ Flags

Enumerator
DONT_SPLIT_FMK 
DONT_REBUILD_LINES 
DONT_REBUILD_ARCS 
DONT_REBUILD_RATIONALS 
DONT_ADJUST_G1 
DONT_MERGE