Rhino C++ API
8.13
|
#include <rhinoSdkRhinoVersion.h>
Static Public Member Functions | |
static unsigned int | App3dmVersionNumber () |
static const char * | AppNameString () |
static const wchar_t * | AppNameWideString () |
static unsigned int | AppSdkServiceReleaseNumber () |
static unsigned int | AppSdkVersionNumber () |
static unsigned int | AppVersionNumber () |
static unsigned int | Branch () |
static const char * | BuildDescriptionString () |
static unsigned int | DayOfMonth () |
static unsigned int | DayOfYear () |
static unsigned int | GetVersionQuartet (unsigned int rhino_version_quartet[4]) |
static unsigned int | GetVersionQuartet (unsigned short rhino_version_quartet[4]) |
static unsigned int | Hour () |
static unsigned int | Major () |
static const char * | MajorString () |
static const wchar_t * | MajorWideString () |
static unsigned int | Minor () |
static unsigned int | Minute () |
static unsigned int | Month () |
static const char * | RegistryRootString () |
static const wchar_t * | RegistryRootWideString () |
static const char * | ServiceReleaseString () |
static const wchar_t * | ServiceReleaseWideString () |
static const char * | VersionQuartetString () |
static const wchar_t * | VersionQuartetWideString () |
static unsigned int | Year () |
This file defines the RhinoVersion class which provides runtime access to Rhinoceros application version information. The RhinoVersion class is part ov the public SDK and is available for use in an C++ Rhino code, plug-in code or library code.
In the rare case that you actually want the C++ prerpocessor defines for this version information, you need to explicitly include rhinoSdkVersion.h. Description: The static functions in the RhinoVersion class provide complete runtime version information about the Rhino.exe application that is running.
|
static |
Returns: The version number of the 3dm file format the Rhino.exe application writes by default. Remarks:
|
static |
|
static |
Returns: The application name this version.
For example, "Rhinoceros 6"
|
static |
Returns: The version number of the Rhino.exe application sdk service release in the form used to identify opennurbs and Rhino SDK versions. Remarks:
|
static |
Returns: The version number of the Rhino.exe application sdk in the form used to identify opennurbs and Rhino SDK versions. Remarks:
|
static |
Returns: The version number of the Rhino.exe application in the form used to identify opennurbs and Rhino SDK versions. Remarks:
|
static |
Returns: RHINO_VERSION_BRANCH 0: developer build 1: Windows Commercial build 2: Mac Commercial build 3: Windows BETA build 4: Mac Beta build 5: Windows WIP build 6: Mac WIP build
|
static |
Returns: A string that describes the build. For a public build, this is something like "Release". For a developer build, this is something like "Private Developer Build".
|
static |
Returns: Day of the month this version was built (1 to 31).
|
static |
Returns: Day of the year this version was built (1 to 366).
|
static |
Parameters: rhino_version_quartet - [out] rhino_version_quartet[0] = major version number rhino_version_quartet[1] = minor version number rhino_version_quartet[2] = (year-2000)*1000 + (day of year) rhino_version_quartet[3] = hour*1000 + minute*10 + branch Returns: RhinoVersion::AppVersionNumber()
|
static |
Parameters: rhino_version_quartet - [out] rhino_version_quartet[0] = major version number rhino_version_quartet[1] = minor version number rhino_version_quartet[2] = (year-2000)*1000 + (day of year) rhino_version_quartet[3] = hour*1000 + minute*10 + branch Returns: RhinoVersion::AppVersionNumber()
|
static |
Returns: Hour of the day this version was built (0 to 23).
|
static |
Returns: Major version number (>=6) For example, 6 for Rhino 6.x.
|
static |
|
static |
Returns: The value of VersionMajor() as a string.
|
static |
Returns: Minor version number (>= 0) For example, 1 for Rhino 6.1
|
static |
Returns: Minute of the hour this version was built (0 to 59).
|
static |
Returns: Month of the year this version was built (1 to 12).
|
static |
|
static |
Returns: The registry root for this version.
For example, "McNeel\\Rhinoceros\\6.0"
|
static |
|
static |
Returns: "SRn" for service release n, where n is an integer. For example, the "SR1" will be returned for service release 1.
|
static |
|
static |
Returns: The version quartet as string of four values separated by periods. For example, "6,0,14065,18590" would be version 6, service release 0, built on 18:19, day 65, year 2014. The final digit identifies the branch.
|
static |
Returns: Year this version was built. ( >= 2014)