Rhino C++ API  8.6
Public Attributes | List of all members
tagMakeRadiusSplineData Struct Reference

#include <rhinoSdkUtilities.h>

Public Attributes

double m_distance
 distance at m_t More...
 
double m_t
 curve parameter More...
 

Detailed Description

Description: Makes a dimension = 1, degree = 3 spline curve that interpolates input values and doesn't overshoot extreme explicitly set in the input values. The output spline will have double knots at each interpolant and 0 derivative at extremes. The domain will be from dist_data[0].t to dist_data[dist_data.Count()-1].t. This makes a good smooth function for interpolating input values along a curve or for use with the RhinoOffsetCurveNormal() function. Parameters: pSrf [in] - Surface from which normals are calculated. pCrv [in] - 3d curve lying on the surface along which normals are calculated. params [in] - parameters in the domain of pCrv for offset points to interpolate pHeights [in] - offset distance (distance from surface to result curve). pHeights is a NURBS curve of dimension 1 with the same domain as pCrv. It is evaluated at points corresponding to the locations where offsets from the surface are calculated to find the height of the offset at those points. Return: ON_NurbsCurve* pointing to offset curve at distance height from the surface. Remarks: Same as the function above, but the offset point locations are specified. THE CALLER IS RESPONSIBLE FOR DESTROYING THE OUTPUT CURVE. See Also: RhinoOffsetCurveNormal

Member Data Documentation

◆ m_distance

double tagMakeRadiusSplineData::m_distance

distance at m_t

◆ m_t

double tagMakeRadiusSplineData::m_t

curve parameter