Click or drag to resize

GH_IWriterCreateChunk Method (String)

Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
GH_IWriter CreateChunk(
	string chunk_name
)

Parameters

chunk_name
Type: SystemString
Name of new child chunk.

Return Value

Type: GH_IWriter
Exceptions
ExceptionCondition
ArgumentException Thrown if the name coordinte is already occupied by another chunk.
See Also