Click or drag to resize

GH_SliderBaseProcessNumber Method

Process a number using the given slider characteristics.

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static decimal ProcessNumber(
	decimal val,
	GH_SliderAccuracy accuracy,
	int digits
)

Parameters

val
Type: SystemDecimal
Number to process.
accuracy
Type: Grasshopper.GUI.BaseGH_SliderAccuracy
Slider rounding accuracy.
digits
Type: SystemInt32
Number of digits to use for floating point rounding.

Return Value

Type: Decimal
Processed number.
See Also