Click or drag to resize

GH_SliderBase Methods

The GH_SliderBase type exposes the following members.

Methods
  NameDescription
Public methodFixDomain
Fix the limits of the slider. Limits will be rounded according to slider type and accuracy. Also, a minimum range for all types is ensured.
Public methodFixValue
Fix the value of the slider. The value will be rounded according to slider type and accuracy. Also, the value will be clipped to the limits. Before you call this function, ensure the limits are set up correctly.
Protected methodHandleTextInputAccepted (Overrides GH_TextBoxInputBaseHandleTextInputAccepted(String).)
Public methodKeyDown
Respond to a KeyDown event.
Public methodMouseDown
Respond to mouse-down events.
Public methodMouseMove
Respond to mouse-move events.
Public methodMouseUp
Respond to mouse-up events.
Public methodOnValueChanged
Raise the ValueChanged event.
Public methodStatic memberProcessNumber
Process a number using the given slider characteristics.
Public methodRender
Render this slider into a Graphics context.
Public methodSetSnapRanges
Assign a collection of snap ranges to this slider.
Public methodShowTextInputBox(Control)
Public methodShowTextInputBox(Control, Boolean)
Public methodShowTextInputBox(Control, Boolean, Matrix)
Public methodShowTextInputBox(Control, Boolean, Matrix, String)
Top
See Also