Click or drag to resize

GH_CapsuleRenderEngineCreateRoundedRectangle Method (Rectangle, Int32)

Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath CreateRoundedRectangle(
	Rectangle rec,
	int radius
)

Parameters

rec
Type: System.DrawingRectangle
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
radius
Type: SystemInt32
Radius of corner fillets.

Return Value

Type: GraphicsPath
Graphics path that describes the rounded rectangle.
See Also