Click or drag to resize

GH_CapsuleRenderEngineCreateRoundedRectangle Method (RectangleF, Single, Single, Single, Single)

Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath CreateRoundedRectangle(
	RectangleF rec,
	float R0,
	float R1,
	float R2,
	float R3
)

Parameters

rec
Type: System.DrawingRectangleF
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
R0
Type: SystemSingle
Radius of upper left corner. Zero or negative values omit fillets.
R1
Type: SystemSingle
Radius of upper right corner. Zero or negative values omit fillets.
R2
Type: SystemSingle
Radius of lower right corner. Zero or negative values omit fillets.
R3
Type: SystemSingle
Radius of lower left corner. Zero or negative values omit fillets.

Return Value

Type: GraphicsPath
Graphics path that describes the rounded rectangle.
See Also