Click or drag to resize

GH_CapsuleRenderEngineCreateRoundedRectangle Method (Rectangle, Int32, Int32, Int32, Int32)

Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath CreateRoundedRectangle(
	Rectangle rec,
	int R0,
	int R1,
	int R2,
	int R3
)

Parameters

rec
Type: System.DrawingRectangle
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
R0
Type: SystemInt32
Radius of upper left corner. Zero or negative values omit fillets.
R1
Type: SystemInt32
Radius of upper right corner. Zero or negative values omit fillets.
R2
Type: SystemInt32
Radius of lower right corner. Zero or negative values omit fillets.
R3
Type: SystemInt32
Radius of lower left corner. Zero or negative values omit fillets.

Return Value

Type: GraphicsPath
Graphics path that describes the rounded rectangle.
See Also