Click or drag to resize

GH_CapsuleRenderEngineGetImpliedStyle Method (GH_Palette, IGH_Attributes)

Static (Shared in VB) method for solving which palette style is implied by the properties.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_PaletteStyle GetImpliedStyle(
	GH_Palette palette,
	IGH_Attributes attributes
)

Parameters

palette
Type: Grasshopper.GUI.CanvasGH_Palette
Palette hint.
attributes
Type: Grasshopper.KernelIGH_Attributes
Attributes to parse for style details.

Return Value

Type: GH_PaletteStyle
See Also