Click or drag to resize

GH_CapsuleRenderEngineGetImpliedStyle Method (GH_Palette, Boolean, Boolean, Boolean)

Static (Shared in VB) method for solving which palette style is implied by the properties.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_PaletteStyle GetImpliedStyle(
	GH_Palette palette,
	bool selected,
	bool locked,
	bool hidden
)

Parameters

palette
Type: Grasshopper.GUI.CanvasGH_Palette
Palette hint.
selected
Type: SystemBoolean
Specifies whether the selected flavour of a palette needs to be returned.
locked
Type: SystemBoolean
If True, the returned palette style is always Locked.
hidden
Type: SystemBoolean
If True, the returned palette style is always Hidden.

Return Value

Type: GH_PaletteStyle
See Also