Click or drag to resize

GH_CapsuleRender Method (Graphics, Image, GH_PaletteStyle)

Have this capsule draw itself onto a Graphics surface with a custom Style override.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void Render(
	Graphics G,
	Image icon,
	GH_PaletteStyle style
)

Parameters

G
Type: System.DrawingGraphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
icon
Type: System.DrawingImage
Icon to render in center of content/bounding box.
style
Type: Grasshopper.GUI.CanvasGH_PaletteStyle
Style to draw capsule with.
See Also