Click or drag to resize

GH_Capsule Methods

The GH_Capsule type exposes the following members.

Methods
  NameDescription
Public methodAddInputGrip(Point)
Add an input grip to this UI Box.
Public methodAddInputGrip(PointF)
Add an input grip to this UI Box.
Public methodAddInputGrip(Single)
Add an input grip to this UI Box. This is the recommended overload.
Public methodAddInputGrip(Single, Single)
Add an input grip to this UI Box.
Public methodAddOutputGrip(Point)
Add an output grip to this UI Box.
Public methodAddOutputGrip(PointF)
Add an output grip to this UI Box.
Public methodAddOutputGrip(Single)
Add an output grip to this UI Box. This is the recommended overload.
Public methodAddOutputGrip(Single, Single)
Add an output grip to this UI Box.
Public methodContains
Test a point for capsule containment.
Public methodStatic memberCreateCapsule(Rectangle, GH_Palette)
Create a new blank capsule with default radius and highlight dimensions.
Public methodStatic memberCreateCapsule(RectangleF, GH_Palette)
Create a new blank capsule with default radius and highlight dimensions.
Public methodStatic memberCreateCapsule(Rectangle, GH_Palette, Int32, Int32)
Create a new blank capsule.
Public methodStatic memberCreateCapsule(Rectangle, GH_Palette, Int32, Int32)
Create a new blank capsule.
Public methodStatic memberCreateCapsule(RectangleF, GH_Palette, Int32, Int32)
Create a new blank capsule.
Public methodStatic memberCreateCapsule(RectangleF, GH_Palette, Int32, Int32)
Create a new blank capsule.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
Create a new capsule with content text.
Public methodStatic memberCreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
Create a new capsule with content text.
Public methodDispose
Protected methodDispose(Boolean)
Public methodRender(Graphics, GH_PaletteStyle)
Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public methodRender(Graphics, Color)
Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public methodRender(Graphics, Image, GH_PaletteStyle)
Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public methodRender(Graphics, Image, Color)
Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public methodRender(Graphics, Boolean, Boolean, Boolean)
Render the capsule onto a graphics context.
Public methodRender(Graphics, Image, Boolean, Boolean, Boolean)
Render the capsule onto a graphics context.
Public methodSetJaggedEdges
Assign left and right jagged edges.
Top
See Also