GH_AnimatorT Constructor (T, T, DateTime, DateTime, GH_AnimatorTInterpolate) |
Create a new instance of the generic animator.
Namespace:
Grasshopper.GUI
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public GH_Animator(
T A,
T B,
DateTime startTime,
DateTime endTime,
GH_AnimatorTInterpolate interpolator
)
Public Sub New (
A As T,
B As T,
startTime As DateTime,
endTime As DateTime,
interpolator As GH_AnimatorTInterpolate
)
Parameters
- A
- Type: T
Start value of animation. - B
- Type: T
End value of animation. - startTime
- Type: SystemDateTime
Start of animation, should be expressed in UTC time. - endTime
- Type: SystemDateTime
End of animation, should be expressed in UTC time. - interpolator
- Type: Grasshopper.GUIGH_AnimatorTInterpolate
Interpolation delegate.
See Also