Click or drag to resize

GH_AnimatorT Class

Provides methods for animating values.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_AnimatorT

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Animator<T>

Type Parameters

T
Data type to animate.

The GH_AnimatorT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyInterpolation
Gets or sets the interpolation mode. Changing the mode during an animation will result in discontinuous motion.
Public propertyPhase
Gets the current animation phase.
Public propertyValueA
Gets or sets the start value of the animation. This value is set from within the constructor though you can change it at any time.
Public propertyValueB
Gets or sets the end value of the animation. This value is set from within the constructor though you can change it at any time.
Top
Methods
  NameDescription
Public methodAdjustAnimation(T)
Adjust the animation.
Public methodAdjustAnimation(T, Int32)
Adjust the animation.
Public methodAdjustAnimation(T, DateTime, DateTime)
Adjust the animation.
Public methodCurrentValue
Gets the current animated value.
Top
See Also