Click or drag to resize

GH_BezierSolverTangentAt Method

Evaluate the tangent vector of a Bezier span.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static SizeF TangentAt(
	ref PointF P0,
	ref PointF P1,
	ref PointF P2,
	ref PointF P3,
	float t
)

Parameters

P0
Type: System.DrawingPointF
Start point of bezier.
P1
Type: System.DrawingPointF
Point for start tangent.
P2
Type: System.DrawingPointF
Point for end tangent.
P3
Type: System.DrawingPointF
End point of bezier.
t
Type: SystemSingle
Unit parameter.

Return Value

Type: SizeF
See Also