Click or drag to resize

GH_SamplingSphereSampleSphere Method (Sphere, GH_MemoryBitmap)

Sample a sphere with a UV texture and return a bitmap of sampled values.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public Bitmap SampleSphere(
	Sphere sphere,
	GH_MemoryBitmap texture
)

Parameters

sphere
Type: Sphere
Sphere to sample, it should be centered on the world origin.
texture
Type: Grasshopper.KernelGH_MemoryBitmap
Texture to sample, the texture will not be modified.

Return Value

Type: Bitmap
A bitmap of Size x Size pixels.
See Also