Click or drag to resize

GH_SamplingSphere Class

Represents a coloured sphere that can be sampled at various rotations.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_SamplingSphere

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_SamplingSphere

The GH_SamplingSphere type exposes the following members.

Constructors
  NameDescription
Public methodGH_SamplingSphere
Initializes a new instance of the GH_SamplingSphere class
Top
Properties
  NameDescription
Public propertySampleCount
Gets the total number of samples contained in this sampling grid.
Public propertySize
Gets the size of this sample grid.
Top
Methods
  NameDescription
Public methodSampleSphere(Sphere)
Sample the UV locations of a sphere. The sphere should be centered on the world origin.
Public methodSampleSphere(Sphere, GH_MemoryBitmap)
Sample a sphere with a UV texture and return a bitmap of sampled values.
Top
See Also