Click or drag to resize

GH_PathOffsetOffsetPath Method (GH_Path, Int32, GH_Path, Int32)

Offset a path + index value without wrapping.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool OffsetPath(
	GH_Path path,
	int index,
	ref GH_Path rel_path,
	ref int rel_index
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path to offset.
index
Type: SystemInt32
Item to offset.
rel_path
Type: Grasshopper.Kernel.DataGH_Path
Offsetted path.
rel_index
Type: SystemInt32
Offsetted index.

Return Value

Type: Boolean
True on success, false on failure.
See Also