Click or drag to resize

GH_PathOffsetOffsetPath Method (GH_Path, Int32, IGH_Structure, GH_Path, Int32)

Offset a path + index value with wrapping and bounds checking.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool OffsetPath(
	GH_Path path,
	int index,
	IGH_Structure tree,
	out GH_Path relativePath,
	out int relativeIndex
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path to offset.
index
Type: SystemInt32
Item to offset.
tree
Type: Grasshopper.Kernel.DataIGH_Structure
Structure context for offset.
relativePath
Type: Grasshopper.Kernel.DataGH_Path
Offsetted path.
relativeIndex
Type: SystemInt32
Offsetted index.

Return Value

Type: Boolean
True on success, false on failure.
See Also