Click or drag to resize

GH_PathIncrement Method (Int32, Int32)

Increment a specific index in this path by one.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_Path Increment(
	int index,
	int offset
)

Parameters

index
Type: SystemInt32
Index to increment. Valis indices are (-Length+1) to (Length-1).
offset
Type: SystemInt32
Amount to increment.

Return Value

Type: GH_Path
A new path with incremented index.
See Also