Click or drag to resize

GH_Path Methods

The GH_Path type exposes the following members.

Methods
  NameDescription
Public methodAppendElement
Create a new path by appending a new index value to this path.
Public methodCompare
Compare two paths. This function determines the Sorting behaviour of paths.
Public methodCompareTo
Compare this path to another path. This function determines the Sorting behaviour of paths.
Public methodCullElement
Removes the last index value from the path. If the path is already empty, nothing will happen.
Public methodCullFirstElement
Removes the first index value from the path. If the path is already empty, nothing will happen.
Public methodFormat
Format a path.
Public methodFromString
Try to deserialize a GH_Path from a String.
Public methodGetHashCode
Specialized Hash code pattern.
(Overrides ObjectGetHashCode.)
Public methodIncrement(Int32)
Increment a specific index in this path by one.
Public methodIncrement(Int32, Int32)
Increment a specific index in this path by one.
Public methodIsAncestor
Test another path to see if it is an ancestor of this path. For a path to be considered an ancestor, it must share the initial dimensions.
Public methodIsCoincident(GH_Path)
Test to see if this path is coincident with another path.
Public methodIsCoincident(Int32)
Test to see if this path is coincident with set of integers.
Public methodPrependElement
Create a new path by prepending a new index value to this path.
Public methodRead
Read this path from an archive.
Public methodStatic memberSplitPathLikeString
Try to split up a path-like formatted string "{A;B;C}(i)" into component parts.
Public methodToString
Concatenates the indices in the path.
(Overrides ObjectToString.)
Public methodToString(Boolean)
Concatenates the indices in the path.
Public methodWrite
Write this path to an archive.
Top
See Also