Click or drag to resize

GH_TreeRules Constructor

Constructs a new rule set for testing data trees. Unless you know exactly what you are doing, use the FromString() static method instead.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_TreeRules(
	IEnumerable<IGH_Rule> pathRules,
	IGH_Rule indexRule
)

Parameters

pathRules
Type: System.Collections.GenericIEnumerableIGH_Rule
A collection of path rules.
indexRule
Type: Grasshopper.Kernel.DataIGH_Rule
Optional index rule (may be null).
See Also