Click or drag to resize

GH_TreeRules Class

Represents an entire data tree rule set.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.DataGH_TreeRules

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_TreeRules

The GH_TreeRules type exposes the following members.

Constructors
  NameDescription
Public methodGH_TreeRules
Constructs a new rule set for testing data trees. Unless you know exactly what you are doing, use the FromString() static method instead.
Top
Properties
  NameDescription
Public propertyHasItemRule
Gets whether this rule set has a defined index rule.
Public propertyHasPathRules
Gets whether this rule set has any path rules.
Public propertyPathRuleCount
Gets the number of defined path rules.
Top
Methods
  NameDescription
Public methodApply(GH_Path)
Apply all the local rules to a path.
Public methodApply(GH_Path, Int32)
Apply all the local rules to a path+index combination.
Public methodStatic memberFromString
Attempt to parse a Pattern string.
Public methodToString (Overrides ObjectToString.)
Top
Fields
See Also