Click or drag to resize

GH_ComponentRuntimeMessages Method

Gets the list of cached runtime messages that were recorded during solver-time processes. For components, the set of runtime messages also includes input and output parameters.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public override IList<string> RuntimeMessages(
	GH_RuntimeMessageLevel level
)

Parameters

level
Type: Grasshopper.KernelGH_RuntimeMessageLevel
Runtime message type to retrieve.

Return Value

Type: IListString
A list of runtime message strings.
See Also