Click or drag to resize

GH_DocumentObjectMenu_AppendItem Method (ToolStrip, String, EventHandler, Image, Boolean, Boolean)

Utility function for appending generic menu items.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static ToolStripMenuItem Menu_AppendItem(
	ToolStrip menu,
	string text,
	EventHandler click,
	Image icon,
	bool enabled,
	bool checked
)

Parameters

menu
Type: System.Windows.FormsToolStrip
Menu to append item to.
text
Type: SystemString
Item text.
click
Type: SystemEventHandler
Delegate that handles click events.
icon
Type: System.DrawingImage
Item icon.
enabled
Type: SystemBoolean
If true, the item will be enabled.
checked
Type: SystemBoolean
If true, the item will be checked.

Return Value

Type: ToolStripMenuItem
The appended item.
See Also