Click or drag to resize

GH_DocumentAutoSave Method (GH_AutoSaveTrigger)

Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool AutoSave(
	GH_AutoSaveTrigger trigger
)

Parameters

trigger
Type: Grasshopper.KernelGH_AutoSaveTrigger
Reason for autosave. User can choose to ignore certain autosave reasons.

Return Value

Type: Boolean
See Also