Click or drag to resize

GH_AutoSaveTrigger Enumeration

Different types of events that can cause an AutoSave.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_AutoSaveTrigger
Members
  Member nameValueDescription
undefined0 Generic autosave trigger, this flag is not filtered.
doc_unload1 Autosave was triggered by a document being unloaded from a Canvas Context.
object_added2 Autosave was triggered by the addition of an object to the document.
object_removed3 Autosave was triggered by the removal of an object from the document.
wire_event4 Autosave was triggered by a change in connector wires.
data_matching_event5 Autosave was triggered by a change to Data Matching settings.
data_modification_event6 Autosave was triggered by a change to Data modifier settings.
object_generic7 Autosave was triggered by a non-trivial change to object data or settings.
See Also