Click or drag to resize

GH_DocumentFindObject Method (Guid, Boolean)

Find the object that matches the ID.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public IGH_DocumentObject FindObject(
	Guid id,
	bool topLevelOnly
)

Parameters

id
Type: SystemGuid
The ID to search for.
topLevelOnly
Type: SystemBoolean
If True, only top-level objects are included. If False, the entire object attribute tree is recursed

Return Value

Type: IGH_DocumentObject
See Also