Click or drag to resize

GH_DocumentFindObjectT Method (Guid, Boolean)

Find the object that matches the ID.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public T FindObject<T>(
	Guid id,
	bool topLevelOnly
)
where T : IGH_DocumentObject

Parameters

id
Type: SystemGuid
The ID to search for.
topLevelOnly
Type: SystemBoolean
If True, only top-level objects are included. If False, the entire object attribute tree is recursed

Type Parameters

T
Object type constraint.

Return Value

Type: T
See Also