Click or drag to resize

GH_FormatFormatFilePath Method (String, Int32)

Format a filepath so that it doesn't exceed a string length. If the filepath filename is already longer than maxLength it will be returned intact.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatFilePath(
	string path,
	int maxLength
)

Parameters

path
Type: SystemString
Path for format.
maxLength
Type: SystemInt32
Maximum number of characters to use.

Return Value

Type: String
The formatted path.
See Also