GH_Format Class |
Namespace: Grasshopper.Kernel
The GH_Format type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | DefaultCulture | |
![]() ![]() | FormatArc(Arc) | |
![]() ![]() | FormatArc(GH_Arc) | |
![]() ![]() | FormatArcValidity |
If the arc is invalid, return a string describing why.
|
![]() ![]() | FormatBoolean(Boolean) | |
![]() ![]() | FormatBoolean(GH_Boolean) | |
![]() ![]() | FormatBoundingBoxValidity |
If the box is invalid, return a string describing why.
|
![]() ![]() | FormatBox(Box) | |
![]() ![]() | FormatBox(GH_Box) | |
![]() ![]() | FormatBoxValidity |
If the box is invalid, return a string describing why.
|
![]() ![]() | FormatBrep(Brep) | |
![]() ![]() | FormatBrep(GH_Brep) | |
![]() ![]() | FormatBrepValidity |
If the brep is invalid, return a string describing why.
|
![]() ![]() | FormatCircle(Circle) | |
![]() ![]() | FormatCircle(GH_Circle) | |
![]() ![]() | FormatCircleValidity |
If the circle is invalid, return a string describing why.
|
![]() ![]() | FormatColour(Color) | |
![]() ![]() | FormatColour(GH_Colour) | |
![]() ![]() | FormatComplexNumber(Complex) | |
![]() ![]() | FormatComplexNumber(GH_ComplexNumber) | |
![]() ![]() | FormatComplexValidity |
If the complex number is invalid, return a string describing why.
|
![]() ![]() | FormatCurve(GH_Curve) | |
![]() ![]() | FormatCurve(Curve, String, String) | |
![]() ![]() | FormatCurveValidity |
If the curve is invalid, return a string describing why.
|
![]() ![]() | FormatDate(DateTime) | |
![]() ![]() | FormatDate(GH_Time) | |
![]() ![]() | FormatDouble(Double) | |
![]() ![]() | FormatDouble(GH_Number) | |
![]() ![]() | FormatDoubleValidity |
If the number is invalid, return a string describing why.
|
![]() ![]() | FormatFilePath(String, Int32) |
Format a filepath so that it doesn't exceed a string length.
If the filepath filename is already longer than maxLength it will be returned intact.
|
![]() ![]() | FormatFilePath(String, Int32, Font) |
Format a filepath so that it doesn't exceed width.
If the filepath filename is already longer than maxLength it will be returned intact.
|
![]() ![]() | FormatGeometry | |
![]() ![]() | FormatInteger(GH_Integer) | |
![]() ![]() | FormatInteger(Int32) | |
![]() ![]() | FormatInterval(GH_Interval) | |
![]() ![]() | FormatInterval(GH_Interval2D) | |
![]() ![]() | FormatInterval(Interval) | |
![]() ![]() | FormatInterval(Double, Double) | |
![]() ![]() | FormatIntervalValidity |
If the point is invalid, return a string describing why.
|
![]() ![]() | FormatKeys |
Format a keys enumeration as though it's a menu shortcut
|
![]() ![]() | FormatLine(GH_Line) | |
![]() ![]() | FormatLine(Line) | |
![]() ![]() | FormatLineValidity |
If the line is invalid, return a string describing why.
|
![]() ![]() | FormatMatrix(GH_Matrix) | |
![]() ![]() | FormatMatrix(Matrix) | |
![]() ![]() | FormatMesh(GH_Mesh) | |
![]() ![]() | FormatMesh(Mesh, String) | |
![]() ![]() | FormatMeshFace | |
![]() ![]() | FormatMeshFaceValidity |
If the number is invalid, return a string describing why.
|
![]() ![]() | FormatMeshValidity |
If the mesh is invalid, return a string describing why.
|
![]() ![]() | FormatPlane(GH_Plane) | |
![]() ![]() | FormatPlane(Plane) | |
![]() ![]() | FormatPlaneValidity |
If the plane is invalid, return a string describing why.
|
![]() ![]() | FormatPoint(GH_Point) | |
![]() ![]() | FormatPoint(Point3d) | |
![]() ![]() | FormatPointCloud | |
![]() ![]() | FormatPointValidity |
If the point is invalid, return a string describing why.
|
![]() ![]() | FormatRectangleValidity |
If the rectangle is invalid, return a string describing why.
|
![]() ![]() | FormatSingle | |
![]() ![]() | FormatSubD(GH_SubD) | |
![]() ![]() | FormatSubD(SubD) | |
![]() ![]() | FormatSubDValidity |
If the brep is invalid, return a string describing why.
|
![]() ![]() | FormatSurface(Brep) | |
![]() ![]() | FormatSurface(GH_Surface) | |
![]() ![]() | FormatSurfaceValidity |
If the surface is invalid, return a string describing why.
|
![]() ![]() | FormatTransformValidity |
If the transform is invalid, return a string describing why.
|
![]() ![]() | FormatVector(GH_Vector) | |
![]() ![]() | FormatVector(Vector3d) | |
![]() ![]() | FormatVectorValidity |
If the point is invalid, return a string describing why.
|
![]() ![]() | RhinoUnitName | |
![]() ![]() | RhinoUnitSymbol | |
![]() ![]() | TreatAsCollection |
This method is used in Scripting components to determine whether a certain class was
'intended' as a collection or as a single piece of data .
|