Click or drag to resize

GH_StateServerRestoreState Method (Int32, Int32, Int32)

Restore a certain state.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool RestoreState(
	int index,
	out int restored_objects,
	out int missing_objects
)

Parameters

index
Type: SystemInt32
Index of state to restore.
restored_objects
Type: SystemInt32
Number of objects successfully restored.
missing_objects
Type: SystemInt32
Number of objects that could not be found.

Return Value

Type: Boolean
True on success, false on failure.
See Also