Click or drag to resize

GH_StateServerRestoreState Method (String, Int32, Int32)

Restore a certain state.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool RestoreState(
	string name,
	out int restored_objects,
	out int missing_objects
)

Parameters

name
Type: SystemString
Name of state to restore. Name is case-sensitive.
restored_objects
Type: SystemInt32
Number of objects successfully restored.
missing_objects
Type: SystemInt32
Number of objects that could not be found.

Return Value

Type: Boolean
True on success, false on failure.
See Also