Click or drag to resize

GH_StateServer Methods

The GH_StateServer type exposes the following members.

Methods
  NameDescription
Public methodNewStateFromDocument
Displays UI for new state creation. If the user aborts, then null is returned. If the user successfully defines a new state, it is appended to this server.
Public methodRead
Public methodRemoveState
Remove a certain state. This method adds an undo record to the document.
Public methodRestoreState(Int32, Int32, Int32)
Restore a certain state.
Public methodRestoreState(String, Int32, Int32)
Restore a certain state.
Public methodRestoreState(Int32, Boolean, Int32, Int32)
Restore a certain state.
Public methodWrite
Top
See Also