Click or drag to resize

GH_UpgradeUtilMigrateOutputParameters Method (IGH_Component, IGH_Component, Int32, Int32)

Migrate a bunch of output parameters.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool MigrateOutputParameters(
	IGH_Component source,
	IGH_Component target,
	int[] index0,
	int[] index1
)

Parameters

source
Type: Grasshopper.KernelIGH_Component
Source component.
target
Type: Grasshopper.KernelIGH_Component
Target component.
index0
Type: SystemInt32
List of output indices to migrate.
index1
Type: SystemInt32
Matching list of target indices.

Return Value

Type: Boolean
True on success, false on failure.
See Also