Click or drag to resize

IGH_Component Interface

Base interface for all GH_Component types. Do not implement this interface from scratch, inherit from GH_Component instead.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_Component : IGH_ActiveObject, 
	IGH_PreviewObject, IGH_BakeAwareObject

The IGH_Component type exposes the following members.

Properties
  NameDescription
Public propertyInConstructor
Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public propertyIsValidMasterParameterIndex
Gets whether the MasterParameterIndex property identifies a valid parameter.
Public propertyMasterParameterIndex
Gets or sets the master parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular master parameter detection will kick in.
Public propertyMessage
Gets or sets a custom message to be displayed underneath the component.
Public propertyParams
Gets the Params object that managed input and output parameters.
Public propertyRunCount
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution. This property will return -1 if no valid runcount is available.
Top
Methods
  NameDescription
Top
See Also