Click or drag to resize

GH_UpgradeUtil Class

Exposes several utility functions for migrating parameters and wires between components useful while upgrading components.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_UpgradeUtil

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_UpgradeUtil

The GH_UpgradeUtil type exposes the following members.

Constructors
  NameDescription
Public methodGH_UpgradeUtil
Initializes a new instance of the GH_UpgradeUtil class
Top
Methods
  NameDescription
Public methodStatic memberMigrateInputParameters(IGH_Component, IGH_Component)
Migrate all input parameters.
Public methodStatic memberMigrateInputParameters(IGH_Component, IGH_Component, Int32, Int32)
Migrate a bunch of input parameters.
Public methodStatic memberMigrateOutputParameters(IGH_Component, IGH_Component)
Migrate all output parameters.
Public methodStatic memberMigrateOutputParameters(IGH_Component, IGH_Component, Int32, Int32)
Migrate a bunch of output parameters.
Public methodStatic memberMigrateRecipients(IEnumerableIGH_Param, IGH_Param)
Utility method for bulk assigning a bunch of sources.
Public methodStatic memberMigrateRecipients(IGH_Param, IGH_Param)
Migrate all recipients from A to B, while maintaining order.
Public methodStatic memberMigrateSources(IEnumerableIGH_Param, IGH_Param)
Utility method for bulk assigning a bunch of sources.
Public methodStatic memberMigrateSources(IGH_Param, IGH_Param)
Migrate all sources from A to B, while maintaining order.
Public methodStatic memberReplaceInputParameters
Move all input parameters from one component to another. Only use this function if the target component can handle the input layout of the source component.
Public methodStatic memberReplaceOutputParameters
Move all output parameters from one component to another. Only use this function if the target component can handle the output layout of the source component.
Public methodStatic memberSwapComponents(IGH_Component, IGH_Component)
Replace an existing component with a different one. All parameters (input and output) will be migrated.
Public methodStatic memberSwapComponents(IGH_Component, Guid)
Replace an existing component with a different one. All parameters (input and output) will be migrated.
Public methodStatic memberSwapComponents(IGH_Component, IGH_Component, Boolean)
Replace an existing component with a different one. All parameters (input and output) will be migrated.
Public methodStatic memberSwapComponents(IGH_Component, Guid, Boolean)
Replace an existing component with a different one. All parameters (input and output) will be migrated.
Top
See Also