Click or drag to resize

GH_UpgradeUtilSwapComponents Method (IGH_Component, Guid)

Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static IGH_Component SwapComponents(
	IGH_Component oldComponent,
	Guid newComponentGuid
)

Parameters

oldComponent
Type: Grasshopper.KernelIGH_Component
Component current in a GH_Document.
newComponentGuid
Type: SystemGuid
ComponentGuid of the component to add.

Return Value

Type: IGH_Component
Component that was added.
See Also