Click or drag to resize

Node3dTNearestItems Method (Double, Double, Double, Int32)

Find the N nearest items.

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public List<Index3d<T>> NearestItems(
	double x,
	double y,
	double z,
	int groupSize
)

Parameters

x
Type: SystemDouble
x coordinate to search from.
y
Type: SystemDouble
y coordinate to search from.
z
Type: SystemDouble
z coordinate to search from.
groupSize
Type: SystemInt32
Number of nearest items to return.

Return Value

Type: ListIndex3dT
A list of nearest items, sorted from nearest to furthest.
See Also