Click or drag to resize

Node3dT Methods

The Node3dT generic type exposes the following members.

Methods
  NameDescription
Public methodAdd
Insert another item into the tree. The item should be within the region of this node.
Public methodAddRange
Insert a collection of items into the tree. The items should all be within the region of this node.
Public methodAddToRhinoDocument
Public methodCollapseNodes
Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.
Public methodFurthestItem(T)
Find the furtest item.
Public methodFurthestItem(Point3d)
Find the furtest item.
Public methodFurthestItem(Double, Double, Double)
Find the furtest item.
Public methodFurthestItem(T, Double, Double)
Find the furtest item.
Public methodFurthestItem(Point3d, Double, Double)
Find the furtest item.
Public methodFurthestItem(Double, Double, Double, Double, Double)
Find the furtest item.
Public methodNearestItem(T)
Find the nearest item.
Public methodNearestItem(Point3d)
Find the nearest item.
Public methodNearestItem(Double, Double, Double)
Find the nearest item.
Public methodNearestItem(T, Double, Double)
Find the nearest item.
Public methodNearestItem(Point3d, Double, Double)
Find the nearest item.
Public methodNearestItem(Double, Double, Double, Validation3dT)
Find the nearest item using custom validation criteria.
Public methodNearestItem(Double, Double, Double, Double, Double)
Find the nearest item.
Public methodNearestItems(T, Int32)
Find the N nearest items.
Public methodNearestItems(Double, Double, Double, Int32)
Find the N nearest items.
Public methodNearestItems(T, Int32, Double, Double)
Find the N nearest items.
Public methodNearestItems(Double, Double, Double, Int32, Double, Double)
Find the N nearest items.
Public methodOptimizeTree
Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.
Public methodRemove(Index3dT)
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public methodRemove(Int32)
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public methodShrinkRegions
Shrink the region for this node and all child nodes. Do not use this method if you intend to add more items later as it creates spatial gaps in the tree structure. You can shrink nodes if you're done adding items and want to start searching the tree.
Public methodSubTree
Gets an iterator for all nodes in this (sub)tree.
Public methodTrimExcess
Trim the excess space on all index lists. You can call this method to reduce memory usage. It will not modify the tree in any functional way.
Top
See Also