Click or drag to resize

GH_Material Methods

The GH_Material type exposes the following members.

Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodStatic memberCreateRhinoMaterial
Creates a standard Rhino material from a colour.
Public methodStatic memberCreateStandardMaterial
Creates a standard Grasshopper material from a colour.
Public methodDuplicate
Duplicate this material.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateMaterial
Duplicate this material.
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodMaterialBestGuess
Gets the best guess RenderMaterial for this shader.
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also