Click or drag to resize

IGH_GeometricGoo Methods

The IGH_GeometricGoo type exposes the following members.

Methods
  NameDescription
Public methodClearCaches
Clears all caches. Typically if the geometry is referenced, this will erase the local copy.
Public methodDuplicateGeometry
Make a complete duplicate of this geometry. No shallow copies.
Public methodGetBoundingBox
Compute an aligned boundingbox.
Public methodLoadGeometry
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodLoadGeometry(RhinoDoc)
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodMorph
Morph the object or a deformable representation of the object.
Public methodTransform
Transforms the object or a deformable representation of the object.
Top
See Also