Click or drag to resize

IGH_GeometricGoo Interface

Base interface for all Data inside Grasshoper that could pass for Geometry

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_GeometricGoo : IGH_Goo

The IGH_GeometricGoo type exposes the following members.

Properties
  NameDescription
Public propertyBoundingbox
Gets the (cached) boundingbox for this geometry. Not all geometry types cache boundingbox results.
Public propertyIsGeometryLoaded
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry.
Public propertyIsReferencedGeometry
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public propertyReferenceID
Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Top
Methods
  NameDescription
Public methodClearCaches
Clears all caches. Typically if the geometry is referenced, this will erase the local copy.
Public methodDuplicateGeometry
Make a complete duplicate of this geometry. No shallow copies.
Public methodGetBoundingBox
Compute an aligned boundingbox.
Public methodLoadGeometry
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodLoadGeometry(RhinoDoc)
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodMorph
Morph the object or a deformable representation of the object.
Public methodTransform
Transforms the object or a deformable representation of the object.
Top
See Also