Click or drag to resize

GH_StructureTDataList Property (Int32)

Gets a direct pointer to the list of data under the specified index.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public List<T> this[
	int index
] { get; }

Parameters

index
Type: SystemInt32
Index of the data branch to retrieve.

Property Value

Type: ListT

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataList(System.Int32)"]

Exceptions
ExceptionCondition
IndexOutOfRangeExceptionThrown if the index does not represent a valid branch.
See Also