Click or drag to resize

GH_Capsule Properties

The GH_Capsule type exposes the following members.

Properties
  NameDescription
Public propertyBox
Gets the outline box for this Capsule.
Public propertyBox_Content
Gets the content box for this Capsule. Text and icons are drawn inside this box.
Public propertyFont
Gets or sets the Font to use for text rendering.
Public propertyHighlight
Gets the highlight size for this Capsule. Zero or negative means there is no highlight.
Public propertyHighlightShape
Gets the graphics path that describes the highlight bar shape of the capsule.
Public propertyInputGrips
Gets the list of locally defined input grip locations.
Public propertyJaggedLeft
Gets whether the left edge of this capsule is jagged.
Public propertyJaggedRight
Gets whether the right edge of this capsule is jagged.
Public propertyMaxRadius
Gets the largest radius defined for this capsule.
Public propertyOutlineShape
Gets the graphics path that describes the outer edge of the capsule.
Public propertyOutputGrips
Gets the list of locally defined output grip locations.
Public propertyPalette
Gets or sets the palette for this Capsule.
Public propertyRadius
Gets the radius of the rounded corners of this Capsule.
Public propertyRenderEngine
Gets the RenderEngine associated with this capsule. You typically don't need to go this far, just use one of the Render() overloads on GH_Capsule directly.
Public propertyText
Gets or sets the text to render in the content box.
Public propertyTextOrientation
Gets or sets the orientation of the text within the content box.
Top
See Also