Click or drag to resize

GH_Document Properties

The GH_Document type exposes the following members.

Properties
  NameDescription
Public propertyAbortRequested
Gets the abortrequested flag state.
Public propertyActiveDoc
Gets or sets a value indicating that this document was last active in a multi-doc aware Rhino.
Public propertyAttributeCount
Returns the total number of attributes in the document. Both Normal and Hidden ones
Public propertyAttributes
Returns a list of all the attributes in this document. This includes attributes for nested objects such as input or output parameters.
Public propertyAuthor
Gets the author details associated with this document.
Public propertyConstantServer
Gets the dictionary of constants defined in this document.
Public propertyContext
Gets or sets the context for this document. Note that the context is not a state so much as an action. Therefore it is not particularly useful to read the context after the fact, rather, context is mostly intended to be a setter, not a getter. When you set the context, all top-level document objects will be informed and the ContextChanged event will be raised.
Public propertyStatic memberDefaultPreviewColour
Gets or sets the default preview colour for normal objects.
Public propertyStatic memberDefaultSelectedPreviewColour
Gets or sets the default preview colour for normal objects.
Public propertyDisplayName
Gets the display name for this document. The display name is highly context sensitive and is only supposed to give the user a good idea of which document this is and whether it has been modified.
Public propertyDocumentID
Gets the document Id. The Id is assigned at construction and never changed. Note: clusters may choose to modify the Id of their internal documents.
Public propertyEnabled
Gets or sets the enabled state for this document. Enabled documents respond to events and display their previews in the Rhino viewport.
Public propertyStatic memberEnableSolutions
Gets or sets a global variable that indicates whether solutions are allowed to be recomputed. When this flag is off, the solver will be disabled and the event watchers should be silent.
Public propertyEventServer
Gets the event server that belongs to this document. The Event server may be in an inactive state, but it is never null.
Public propertyFilePath
Gets or sets the file path of this document. If the file path is not set Nothing is returned.
Public propertyIgnoredCount
Returns the total numbers of components currently in the Object Exception Ignore List.
Public propertyIsFilePathDefined
Returns True if the filename flag of this document has been set
Public propertyIsModified
Gets or sets the modified flag. If the new value differs from the old value, the ModifiedChanged() event is raised.
Public propertyModifiedSubsidiaries
Gets the number of modified subsidiary documents.
Public propertyNested
Gets or sets whether this document is nested. A nested document is always part of some other document and is therefore unknown to the DocumentServer and the Canvas.
Public propertyObjectCount
Returns the total number of top-level objects in the document.
Public propertyObjects
Returns a list of all normal, top-level objects.
Public propertyObjectSpan
Gets the total timespan for all objects.
Public propertyOwner
Gets or sets the owner of this document. A document is typically owned when it is subsidiary to some object, such as a cluster.
Public propertyPreviewBoundary
Gets or sets the preview boundary applied to this document. If a boundary has been set, only those objects which are inside the boundary will be previewed.
Public propertyPreviewBoundingBox
Gets the boundingbox used for previews.
Public propertyPreviewColour
Gets or sets the colour of unselected preview geometry.
Public propertyPreviewColourSelected
Gets or sets the colour of selected preview geometry.
Public propertyPreviewCustomMeshParameters
Gets or sets the Custom Meshing Parameters for this document, these are only used when PreviewMeshType = GH_PreviewMesh.Custom
Public propertyPreviewFilter
Gets or set the preview filter.
Public propertyPreviewMeshType
Gets or sets the preview mesh type for this document.
Public propertyPreviewMode
Gets or sets the preview display mode and makes sure the conduit instance of this class is set to match.
Public propertyProfiler
Gets or sets the profiler mode used in this document.
Public propertyProperties
The properties of this document
Public propertyRaiseEvents
If RaiseEvents is set to false, all the On....() methods of this document will stop raising events.
Public propertyRemotePanelLayout
Gets the Remote Control Panel layout for this document.
Public propertyRhinoDocument
Public propertyRuntimeID
Gets the runtime ID of this document. RuntimeID is assigned once and never changed. It is also not deserialized so every document will always have a unique ID when loaded.
Public propertyScheduleDelay
Gets the delay for the next scheduled solution. If there is no solution scheduled the delay will be negative.
Public propertySelectedCount
Gets the number of selected objects
Public propertySelectionTopology
Gets the selection topology of the document.
Public propertySolutionDepth
Gets the number of nested solutions currently running. If no solutions are running, the depth should be zero. If one solution is runnnig, the depth should be one. Higher depths are only possible if a new solution was scheduled from within an existing solution with delay=0ms.
Public propertySolutionHistory
Gets a list of the last 1000 solution timespans, from oldest to youngest.
Public propertySolutionSpan
Gets the timespan for the most recent solution.
Public propertySolutionState
Gets the state of this document.
Public propertyStateServer
Gets the list of stored states in this document
Public propertyThumbnail
Gets or sets the thumbnail bitmap for this document.
Public propertyUndoServer
Gets the UndoServer instance that belongs to this document.
Public propertyUndoUtil
Gets a temporary undo utility instance that allows you to easily create standard undo events.
Public propertyValueTable
Gets the value table associated with this document.
Top
See Also