Click or drag to resize

GH_FileWatcher Properties

The GH_FileWatcher type exposes the following members.

Properties
  NameDescription
Public propertyActive
Gets or sets the active flag on this watcher.
Public propertyBuffer
Gets or sets the time during which events are buffered. If multiple events for the same file occur within the buffered timespan, they will be merged into one event.
Public propertyInvokeOnDefaultThread
Gets or sets invoke behaviour for events. If true, then the event delegate is called via the Grasshopper main UI thread. This is almost always what you need.
Public propertyIsDisposed
Public propertyPath
Gets the file or folder path currently being watched.
Top
See Also