Click or drag to resize

Node3dT Properties

The Node3dT generic type exposes the following members.

Properties
  NameDescription
Public propertyCenter
Gets the center of the spatial region of this node. If the node contains no children the center is always in the middle of the Region. If the node does contain child-nodes, the center may be anywhere within the region.
Public propertyChildCount
Gets the number of defined child nodes. Leaf nodes have no children. Root and twig nodes can have anywhere between 1 and 8 children.
Public propertyChildNode
Gets the child node at the given index.
Public propertyContentAverage
Returns the average coordinate of all items in this node. If this node does not contain any items, Point3d.Unset is returned.
Public propertyContentBoundingBox
Returns the boundingbox of all items in this node. If this node does not contain any items, BoundingBox.Empty is returned.
Public propertyIndicesLocal
Gets the list of item indices that are contained within this node.
Public propertyIndicesRecursive
Gets the list of item indices that are contained within this node and any child nodes.
Public propertyIsLeaf
Gets whether this node is a leaf node. Leaf nodes have no child nodes.
Public propertyIsMutable
Gets whether this tree is mutable. You can only add items to mutable trees. We don't recommend removing items from unmutable trees, though that shouldn't necessarily lead to problems. Trees become unmutable after a call to ShrinkRegions(), CollapseNodes() or OptimizeTree().
Public propertyIsRoot
Gets whether this node is a root node. Root nodes have no parent node and depth zero.
Public propertyIsTwig
Gets whether this node is a twig node. Twig nodes have both parents and at least one child.
Public propertyItemCount
Gets the total number of items stored directly in this node.
Public propertyItemsGlobal
Gets the list of all items stored inside this entire tree. Do not modify this collection unless you know what you are doing.
Public propertyItemsLocal
Gets a list of all the items stored directly in this node. This list is constructed every time you access this property, so keep it down to a minimum.
Public propertyLimit
Gets the subdivision limit for this tree. This limit can only be set once when you create a new tree. It is fixed forever after.
Public propertyMemoryConsumption
Gets the estimated memory consumption of the (sub)tree structure. Items inside the global list are not included in this estimate.
Public propertyNextNode
Gets the logical neighbour to the right of this node. There is no spatial relationships between logical neighbours, this is purely an iteration aid.
Public propertyNodeDepth
Gets the recursive depth of this node. The tree root is at depth zero. The first subdivision is at depth one, and so on and so forth.
Public propertyParentNode
Gets the immediate parent of this node. Root nodes have no parent.
Public propertyRegion
Gets the spatial region of this node.
Public propertyRootNode
Gets the ultimate root node for this tree.
Public propertyWeightedSubdivision
Gets or sets whether subdivision is weighted based on content averages. Setting this value will only affect future subdivisions, not existing ones.
Top
See Also