Click or drag to resize

GH_GeometricGooT Properties

The GH_GeometricGooT generic type exposes the following members.

Properties
  NameDescription
Public propertyBoundingbox
Gets the boundingbox for this geometry.
Public propertyIsGeometryLoaded
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public propertyIsReferencedGeometry
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public propertyIsValid
Gets a value indicating whether or not the current value is valid.
(Overrides GH_GooTIsValid.)
Public propertyReferenceID
Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty.
Public propertyValue
Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future.
(Overrides GH_GooTValue.)
Top
See Also